100 Meg Internet Connection & slow VPN Speed Issue

A couple weeks ago Time Warner sent me an email that they were offering a free upgrade to my Turbo Internet service which was 10 meg down / 2 meg up.   The new speed is up to 100 Meg down / 10 meg up.

I got the new cable box which was an Arris DG1670A Docsis 3.0 Gateway.

I connected it up and shipped back the old cable box to Time Warner.

The Arris is a combo cable box and router with built in Wifi and 4 Ethernet connections.   I tried to configure it so that my Netgear nighthawk router would stay the same, but no luck.  Called Time Warner and the tech configured my Arris to just be a GATEWAY instead of a router and all is working. 

Speed tests are variable, but using the speed test from timewarner I have been able to see over 100 meg  down and 11 meg up  when connected to server 01 - Austin Texas.  Server 02 and Server 03 have been slower. 

speedguide.net - 3 down, 4 up

Speakeasy.net  - 14 meg down, 10 up

speedtest.net - 71 meg down, 10 up

I set this up on Friday and on Monday, IBM's standard software installer pushed an update to my machine that was taking forever to complete.   It actually failed 2 times and on the 3 time, I watched it closer and did a full upgrade of the software, but it took over 7 hours to finish.   I went and did a test with Free Download Manager and downloaded a 20 meg file off of our file storage system.   Data was only coming down at 20-30k.  I might as well go back to a phone line modem...

These were things I tried to resolve this issue:

1) I was using the AT&T network client 8.2 (I think it was) and saw some posts in the forum of similar issues so I upgraded to the V9.5.0.3001 client and reran the test.  No luck

2) I tried changing the MTU size on the AT&T Net client.  No Luck

3) I tried using the optimizer tool on http://www.speedguide.net/ .   No Luck

4) I tried changing the default network setting to Both the Internet and my company's internet with Managed VPN - IPSec.  No Luck

5) I tried changing the default network setting to Both the Internet and my company's internet with Managed VPN - SSL DualAccess.  Bingo - 400-800k down

Now, I don't have anything documented of VPN speed before I put the new gateway box in place, but I know I was not experiencing 20-30k connections.   

Hope this helps someone down the road....